Toucan Firmware Release V1.34

Post Reply
TimH
JT Innovations
Posts: 667
Joined: Wed Sep 01, 2010 2:51 pm

Toucan Firmware Release V1.34

Post by TimH »

Toucan firmware V1.34 and a corresponding new User Guide are available for download now from the JTi website

This release:
  • Fixes issues relating to the ALS indicator on the main gauge screens.
  • Fixes an issue whereby choice to use 12 CALs rather than 8 was not remembered.
  • Fixes an issue that could cause erroneous text to appear in the traction control/ALS map area of the main gauge screen.
  • When CAN control is enabled (for CAL and ALS selection) the grey "cal" wire can now be used as a 0-5V switch for launch control on/off, or (as per V1.30) for traction control calibration selection.
  • New generic Status Indicators. These can be configured to be displayed in place of the one or both of the smallest gauges on the main gauge screens and, by appropriate CANbus datastream assignment, can then display parameters that have simple status values (0, 1, 2 and.or 3) such as water injection state.
  • there is a now a duplicate set of many gauges such as coolant temp, air temp, oil temp etc. Although originally implemented for a twin-engined, dual-Syvecs vehicle, these gauges can be used to display values of other similarly-scaled parameters such as air inlet as well as air charge temperature, or transmission oil temperature etc.
johnfelstead
Posts: 26
Joined: Wed Jan 29, 2014 12:23 am

Re: Toucan Firmware Release V1.34

Post by johnfelstead »

Hi Tim, thanks for the update.

I am trying to use the Water Injection status display in the new firmware, how do I do this?

I set the datastreams to give Frame 12 slot 1 to Water Injection, but don't see how I can program the status? Is this Automatically done correctly by the Syvecs and interpreted correctly by the Toucan?

Any chance of the Turbo Speed Gauge in the next release? :mrgreen:

cheers
john
TimH
JT Innovations
Posts: 667
Joined: Wed Sep 01, 2010 2:51 pm

Re: Toucan Firmware Release V1.34

Post by TimH »

Sounds like the Syvecs and is set up right, at the toucan end you will need to select status 1 as one of the tiny gauges on one or more gauge pages. Give me a call whenever suits, and I can help get it set up.

And, yes, will add turbo speed as soon as I can :)
johnfelstead
Posts: 26
Joined: Wed Jan 29, 2014 12:23 am

Re: Toucan Firmware Release V1.34

Post by johnfelstead »

Thanks Tim.

Took it for a quick run tonight and the WI status light is working OK when the WI switches on/off.

Bit of an odd one though, the LC status disappeared off the screen as soon as I gave it full throttle and the WI status went green. LC status then reappeared when I slowed the car to a stop with engine still running, prior to stopping it just stayed missing from the screen. Never seen that before? Don't know if that's a result of me running the WI status or just the firmware update in general?

cheers
john
TimH
JT Innovations
Posts: 667
Joined: Wed Sep 01, 2010 2:51 pm

Re: Toucan Firmware Release V1.34

Post by TimH »

I'll check and report back :)
TimH
JT Innovations
Posts: 667
Joined: Wed Sep 01, 2010 2:51 pm

Re: Toucan Firmware Release V1.34

Post by TimH »

You're right John, sorry :(

When you use the (redundant) CAL switch output to control launch control on/off I was incorrectly mapping one of the status values to "hide" rather than "yellow!.

I've emailed you a file and if you have a chance to test it, it would be much appreciated :)
johnfelstead
Posts: 26
Joined: Wed Jan 29, 2014 12:23 am

Re: Toucan Firmware Release V1.34

Post by johnfelstead »

Thanks Tim,

I've installed the new file and that's fixed the LC status.

Cheers
john
TimH
JT Innovations
Posts: 667
Joined: Wed Sep 01, 2010 2:51 pm

Re: Toucan Firmware Release V1.34

Post by TimH »

V1.35 on the website now :)
Post Reply