Analog inputs filtering routine

Post Reply
tpepmeie
Posts: 10
Joined: Sun Sep 22, 2013 12:32 am

Analog inputs filtering routine

Post by tpepmeie »

I read somewhere that the filtering was different ("better") on AN #9-#16 inputs. Can anybody confirm this or explain the difference?

And, I have the filter set to zero for both cam and crank position inputs. I assume this is the preferred configuration?
Todd
tpepmeie
Posts: 10
Joined: Sun Sep 22, 2013 12:32 am

Re: Analog inputs filtering routine

Post by tpepmeie »

As a follow-up to this, I've got my crank sensor (VR) assigned to AN#09, pin 39. Cam sensor (HE) assigned to AN#11, pin 38.

The S8 wiring guide has these on pin 41 (AN#08), and pin 42 (AN#06).

Is my setup acceptable, or is there something unique about the filtering which would mean I should choose the other pins?

Cheers,
Todd
Ryan.g
Syvecs Staff - Caretaker
Posts: 287
Joined: Fri May 30, 2008 3:05 pm

Re: Analog inputs filtering routine

Post by Ryan.g »

Its always best to have the filtering OFF in my experiences for the Crank and Cam, if you are experiences noise on these it important to fix it properly via better wiring setup.

There is no difference in the filtering between the AN Inputs.

Using AN09 and AN11 for the Crank and cam is fine on a S8. Would not be fine on a S6 as only AN1-8 are frequency inputs
tpepmeie
Posts: 10
Joined: Sun Sep 22, 2013 12:32 am

Re: Analog inputs filtering routine

Post by tpepmeie »

Appreciate the response, Ryan.

Related question - is it acceptable to provide 12v to the cam sensor via the ECU (pin 56 or 57)? Makes the loom tidier. In fact, I'd like to power both the Cam sensor and IACV (Bosch 2-wire) from the same pin.

It doesn't appear that these two should draw many amps.

Thanks,
Ryan.g
Syvecs Staff - Caretaker
Posts: 287
Joined: Fri May 30, 2008 3:05 pm

Re: Analog inputs filtering routine

Post by Ryan.g »

That would be fine
Post Reply