Pin does not support the required input config

Post Reply
Grabla66
Posts: 72
Joined: Tue Oct 25, 2016 7:01 am
Location: Fordshire
Contact:

Pin does not support the required input config

Post by Grabla66 »

I'm trying to use AN#16 (GEN) C1-08 on my F88 ECU as an Exh VVT sensor input. It was previously used for Steering Wheel Angle input but I'm trying to reassign it.

I've unassigned it from SWA, but if I try to assign it to CAM EXH VVT, I see Pin does not support the required input config when I try to program the ECU.

I've set the Cam Sensor Type to Thermistor, Input Filter ON, High Trigger 3V, Lo Trigger 2V, and Rising Edge, which is the same config as the sensor used on the Inlet VVT sensor.

Is it that the Input I'm using doesnt support Thermistor so I need to choose a different input altogether? It is labelled as (GEN) which I thought meant it was 'all of the above' , ie 5V/TH/BI/FREQ

If instead I just chose 5V for the sensor, which is how it was used when it was the Steering Wheel Angle input, will the cam sensor work reliably?

[edit] I tried settting the sensor to 5V and I stll get the Pin does not support message :(
stevieturbo
Posts: 961
Joined: Sun Dec 07, 2008 2:04 pm

Re: Pin does not support the required input config

Post by stevieturbo »

AN16 is listed as a configurable input on the S8, so should be able to be used for pretty much any option.

Thermistor applies the internal pullup to the input.

Whether or not you get a signal with either depends whether the sensor pulls to ground or offers a voltage.

Simple answer....log it and see whilst cranking. Both the raw AN16 input and the actual channel used, say at 1000Hz to get a good waveform/reading.

Worst case, wire in an external pullup in 5v mode.
Grabla66
Posts: 72
Joined: Tue Oct 25, 2016 7:01 am
Location: Fordshire
Contact:

Re: Pin does not support the required input config

Post by Grabla66 »

I reckon its the reduced IO in my ECU Stevie. AN#11 works as inlet VVT, but AN#16 doesnt. It must be AN#16 doesnt support frequency inputs and the ECU refuses to allow the CAL to assign VVT to an input that isnt going to work.

When I've moved my CAL switches to the Dashboard CAN Switch, I'll have three free inputs on the X10 that I can use. I'll reassign one of those to VVT instead.
TimH
JT Innovations
Posts: 661
Joined: Wed Sep 01, 2010 2:51 pm

Re: Pin does not support the required input config

Post by TimH »

It may not like VVT on X10 inputs either as it can't reliably get the data, via CAN, to sync up correctly.

If its an F88R it only has 8 frequency-capable inputs and I suspect AN16 isn't one of them!
stevieturbo
Posts: 961
Joined: Sun Dec 07, 2008 2:04 pm

Re: Pin does not support the required input config

Post by stevieturbo »

I don't think you're supposed to put any crank phased inputs into the X10, which any cam signal would be.

If it is accepting the input as a 5v input, then it just sounds like it isnt a configurable input, ie it cannot offer a pullup on that input. As said, no big deal, just do it externally if it is actually needed.
Grabla66
Posts: 72
Joined: Tue Oct 25, 2016 7:01 am
Location: Fordshire
Contact:

Re: Pin does not support the required input config

Post by Grabla66 »

I have an email from Life that says the X10 can be used for VVT.

However the ecumaster steering wheel CAN switch I'm just fitting is going to free up five analogue inputs on my X10 so I will look at moving the front wheel speed sensors from the ECU to the X10 and then I can Wire the VVT to the ECU speed sensor input.
Post Reply