S7 Vbat Voltage readings

Post Reply
torana
Posts: 10
Joined: Fri Aug 11, 2017 9:28 am

S7 Vbat Voltage readings

Post by torana »

with my S7 PNP I am having issue with the Vbat reading, ignition off is 9v engine running reads around 11v

with multimeter battery voltage is 11.5 charging voltage at the battery is 14.2 engine running different to S7

also I am unable to change fuelling through adjusting the numbers at idle and is rich around 11.0afr , rev the engine past 2500rpm I can then adjust the fueling to desired afr

any thoughts

stevieturbo
Posts: 898
Joined: Sun Dec 07, 2008 2:04 pm

Re: S7 Vbat Voltage readings

Post by stevieturbo »

torana wrote:
Mon Dec 30, 2019 5:48 am
with my S7 PNP I am having issue with the Vbat reading, ignition off is 9v engine running reads around 11v

with multimeter battery voltage is 11.5 charging voltage at the battery is 14.2 engine running different to S7

also I am unable to change fuelling through adjusting the numbers at idle and is rich around 11.0afr , rev the engine past 2500rpm I can then adjust the fueling to desired afr

any thoughts
A reading of 9v sounds ridiculously low and would imply some sort of wiring or connector issue.

But then if you're also saying that with a multimeter battery voltage is 11.5v charging....that is far too low too.

If you measure voltage at the relevant pins in the ecu connector, how do they compare with at the battery ?

torana
Posts: 10
Joined: Fri Aug 11, 2017 9:28 am

Re: S7 Vbat Voltage readings

Post by torana »

Found the problem to be the internal fuse have a issue not supplying correct voltage.
All fixed now vbatt now showing actual car voltage

stevieturbo
Posts: 898
Joined: Sun Dec 07, 2008 2:04 pm

Re: S7 Vbat Voltage readings

Post by stevieturbo »

internal fuse where ?

On the car somewhere or the ecu ?

torana
Posts: 10
Joined: Fri Aug 11, 2017 9:28 am

Re: S7 Vbat Voltage readings

Post by torana »

On the ecu board, all sorted now

Post Reply